502 bad gateway


#1

Each time I connect google colab to fastai notebook, after installation is complete it gives 502 gateway (nginx/1.10.3 (Ubuntu)) on clicking jupyter notebook button.
while the terminal button works and the data is loaded successfully.

any suggestions?


#2

Hi Amr

We are looking into this. Will keep you posted.

-Prakash


#3

Prakash, I am experiencing the same problem not with “fastai” but with a custom project I created. Ternimal works but Jupyter gives " 502 Bad Gateway

nginx/1.10.3 (Ubuntu)"

Thanks!


#4

You are also using Google Colab?


#5

I have a same problem 502 bad gateway. Yes, I am using google colab


#6

Thanks for reporting this guys. This was due to some change from Google in their default Colab environment. I have published a fix for this just now.

Give it a try and let me know if you still see the issue.

-Prakash


#7

It worked. Thanks :slight_smile:


#8

Thank you, It worked


#9

Thanks, Prakash! It worked.


#10

Hi,

I’m still getting this error . May I know if I’ve to do something on my end to fix this .


#11

Hi Amr ,
May I know how did you fix this ?


#12

No action should be needed from your side.

Can you verify if its just JupyterLab which gives error or the remote terminal also doesn’t work? If both terminal and JupyterLab are not working, then mostly your Colab instance is terminating.


#13

Running google colab from different browser (opera) and clouderizer on firefox worked and the notebook was always connected but later I found some error.

I don’t know if it worked by chance or it has a real effect.


#14

Where can I find the fix ?


#15

Still getting this 502 bad gateway error .


#16

no more getting this one . Resolved


#17

I’m still getting 502 bad gateway error while running scripts.


#18

I think the 502 bad gateway error that we are getting now is due to Google colab getting terminated . @prakash ,In case of termination of google colab , we have to connect it again and run the !wget command which restarts our Jupyterlab instance hence all the saved work is gone . Is there any way to get started from where we left ?


#19

Clouderizer backs up your /code, /data and /out folder every minute. So any changes you do must be getting saved in your Google Drive. Next time when you restart the project, it should resume from where you left.

Let me know if you are experiencing otherwise.

-Prakash


#20

hello! I have the same 502-bad-gateway issue