Google Colab Clouderizer


#1

I have been trying to use Clouderizer with Google Colab based on the instructions provided https://medium.com/@prakash_31206/fastest-way-to-setup-fast-ai-course-notebooks-for-free-using-google-colab-gpu-and-clouderizer-c8a004e1d50d It worked fine the first time round but subsequent attempts have been failing. The display on Clouderizer just indicates that the machine is not running even after going through and completing all the stages.


#2

Hi…can you try refresh your browser console and check if status changes to Running?
If it doesn’t, can you post your Google Colab notebook output here. It will help us analyse what might be going wrong.

-Prakash


#3

Google Golab Notebook Output here https://gist.github.com/thufirtan/f51abc8a16759d2dac716ed62dec4c7a

On Clouderizer it runs through the various stages but finally when everything is completed the project is Not Running even after I refreshed


#4

Output looks perfectly fine.

Is the Colab notebook code block still executing (with a loading indicator) or has finished (with a play icon)?


#5

It has finished with a play icon


#6

OK. This means service stopped due to some reason. Can you run this snippet in another code block?

!cat /tmp/cldz.out

and send me its output.


#7

[main] INFO com.clouderizer.client.utils.Logger - Starting Clouderizer version 1.0
[main] INFO com.clouderizer.client.utils.Logger - Home: /root user: root
[ClouderizerService#1525058994162] INFO com.clouderizer.client.utils.Logger - Starting Service…
[ClouderizerService#1525058994162] INFO com.clouderizer.client.utils.Logger - Output from Server …

java.io.FileNotFoundException: /content/.clouderizer/project.json (No such file or directory)
at java.io.FileOutputStream.open0(Native Method)
at java.io.FileOutputStream.open(FileOutputStream.java:270)
at java.io.FileOutputStream.(FileOutputStream.java:213)
at java.io.FileOutputStream.(FileOutputStream.java:101)
at java.io.PrintWriter.(PrintWriter.java:184)
at com.clouderizer.client.utils.ClientToServer.ClouderizerGet(ClientToServer.java:102)
at com.clouderizer.client.service.ClouderizerService.run(ClouderizerService.java:114)
[ClouderizerService#1525058994162] ERROR com.clouderizer.client.utils.Logger - Error in Clouderizer Service
java.lang.NullPointerException
at com.clouderizer.client.utils.ClouderizerUtil.GetBooleanFromJson(ClouderizerUtil.java:106)
at com.clouderizer.client.service.ClouderizerService.run(ClouderizerService.java:134)
[ClouderizerService#1525058994162] ERROR com.clouderizer.client.utils.Logger - Stopping Service
[Thread-0] INFO com.clouderizer.client.utils.Logger - echo Exiting clouderizer agent > /content/temp.sh
[Thread-0] INFO com.clouderizer.client.utils.Logger - Output from Server …

[Thread-0] INFO com.clouderizer.client.utils.Logger - About to kill tmux session


#8

Logs above helped. I guess issue should be resolved now.
Can you try running your project now?


#9

Thanks! It’s working now. Anything I did wrong or was it some bug you had to fix?


#10

It was a bug. I fixed it.


#11

Hello

I’m getting a syntax error on connecting Clouderizer with Google Collab ipynb notebook. I followed the steps mentioned in your article.
Following is the error:

File “”, line 1
wget -NS --content-disposition “https://console.clouderizer.com/givemeinitsh/RStxRtqE” && bash ./clouderizer_init.sh
^
SyntaxError: invalid syntax

Kindly help!


#12

You need to put one ! before the command to run on Jupyter Notebook. Final command would be
!wget -NS --content-disposition “https://console.clouderizer.com/givemeinitsh/RStxRtqE” && bash ./clouderizer_init.sh

-Prakash