Stuck at "Starting clouderizer service"


#1

I was using it to run fast.ai lesson 1. First time I could setup everything properly and the code ran fine.
Today I copied the same start up script and ran it in colab… but on clouderizer its stuck at “Starting clouderizer service”… Hence I cant open the notebook or do anything… Waited a long time as well.


#2

Can you post here the output from Google Colab notebook cell?

Also, from a new cell on Colab notebook, run the following command
!cat /tmp/cldz.out

This should output Clouderizer service logs. Please post these logs as well.

-Prakash


#3

–2018-05-28 19:40:11-- https://console.clouderizer.com/givemeinitsh/R8jdrsvx
Resolving console.clouderizer.com (console.clouderizer.com)… 34.228.182.208
Connecting to console.clouderizer.com (console.clouderizer.com)|34.228.182.208|:443… connected.
HTTP request sent, awaiting response…
HTTP/1.1 200 OK
Server: nginx/1.10.3 (Ubuntu)
Date: Mon, 28 May 2018 19:40:12 GMT
Content-Type: application/octet-stream; charset=utf-8
Content-Length: 7667
Connection: keep-alive
X-Powered-By: Sails <sailsjs.org>
Access-Control-Allow-Origin:
Access-Control-Allow-Credentials:
Access-Control-Allow-Methods:
Access-Control-Allow-Headers:
Access-Control-Expose-Headers:
Content-Disposition: attachment; filename="clouderizer_init.sh"
ETag: W/"1df3-8TyWKhT1DAYnHsY7FqbEKg"
set-cookie: sails.sid=s%3ADixRhov0cyw23Bu3NCFnj1mrelQYnOtl.GYs%2FRTwjkpbPk9FndVHS%2BLDSedxNKYMWeYgWNJFLfy4; Path=/; HttpOnly
Length: 7667 (7.5K) [application/octet-stream]
Last-modified header missing – time-stamps turned off.
–2018-05-28 19:40:12-- https://console.clouderizer.com/givemeinitsh/R8jdrsvx
Reusing existing connection to console.clouderizer.com:443.
HTTP request sent, awaiting response…
HTTP/1.1 200 OK
Server: nginx/1.10.3 (Ubuntu)
Date: Mon, 28 May 2018 19:40:12 GMT
Content-Type: application/octet-stream; charset=utf-8
Content-Length: 7667
Connection: keep-alive
X-Powered-By: Sails <sailsjs.org>
Access-Control-Allow-Origin:
Access-Control-Allow-Credentials:
Access-Control-Allow-Methods:
Access-Control-Allow-Headers:
Access-Control-Expose-Headers:
Content-Disposition: attachment; filename="clouderizer_init.sh"
ETag: W/"1df3-8TyWKhT1DAYnHsY7FqbEKg"
Length: 7667 (7.5K) [application/octet-stream]
Saving to: ‘clouderizer_init.sh’

clouderizer_init.sh 100%[===================>] 7.49K --.-KB/s in 0s

2018-05-28 19:40:12 (698 MB/s) - ‘clouderizer_init.sh’ saved [7667/7667]

Linux version 4.4.111+ (chrome-bot@build115-m2.golo.chromium.org) (gcc version 4.9.x 20150123 (prerelease) (4.9.2_cos_gg_4.9.2-r175-0c5a656a1322e137fa4a251f2ccc6c4022918c0a_4.9.2-r175) ) #1 SMP Tue Mar 20 23:18:55 PDT 2018
Starting Clouderizer…
If you are running clouderizer for first time on this machine, it might take some time (~10 mins) to install all pre-requisite frameworks.
Get:1 http://security.ubuntu.com/ubuntu artful-security InRelease [83.2 kB]
Hit:2 http://archive.ubuntu.com/ubuntu artful InRelease
Get:3 http://archive.ubuntu.com/ubuntu artful-updates InRelease [88.7 kB]
Get:4 http://archive.ubuntu.com/ubuntu artful-backports InRelease [74.6 kB]
Fetched 247 kB in 1s (198 kB/s)
Reading package lists… Done
default-jre is not installed, installing…
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
default-jre : Depends: default-jre-headless (= 2:1.8-59ubuntu1) but it is not going to be installed
Depends: openjdk-8-jre but it is not going to be installed
openjdk-8-jre-headless : Depends: ca-certificates-java but it is not going to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).
openssh-server is not installed, installing…
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
openjdk-8-jre-headless : Depends: ca-certificates-java but it is not going to be installed
openssh-server : Depends: openssh-sftp-server but it is not going to be installed
Depends: libwrap0 (>= 7.6-4~) but it is not going to be installed
Recommends: libpam-systemd but it is not going to be installed
Recommends: ncurses-term but it is not going to be installed
Recommends: xauth but it is not going to be installed
Recommends: ssh-import-id but it is not going to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).
tmux is not installed, installing…
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
openjdk-8-jre-headless : Depends: ca-certificates-java but it is not going to be installed
tmux : Depends: libevent-2.1-6 (>= 2.1.8-stable) but it is not going to be installed
Depends: libutempter0 (>= 1.1.5) but it is not going to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).
autossh is not installed, installing…
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
openjdk-8-jre-headless : Depends: ca-certificates-java but it is not going to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).
The bzip2 package has already been installed.
The git package has already been installed.
The unzip package has already been installed.
The curl package has already been installed.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 4178 100 4178 0 0 4178 0 0:00:01 --:–:-- 0:00:01 7541
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 13 100 13 0 0 13 0 0:00:01 --:–:-- 0:00:01 23

The latest version of rclone rclone v1.41 is already installed.

Requirement already up-to-date: pip in /usr/local/lib/python3.6/dist-packages (10.0.1)
plotnine 0.3.0 has requirement scipy>=1.0.0, but you’ll have scipy 0.19.1 which is incompatible.
jupyter 1.0.0
jupyter-client 5.2.3
jupyter-console 5.2.0
jupyter-core 4.4.0
The jupyter package has already been installed.
matplotlib 2.1.2
The matplotlib package has already been installed.
tensorflow 1.8.0
tensorflow-hub 0.1.0
The tensorflow package has already been installed.
keras is not installed, installing…
Requirement already satisfied: keras in /usr/local/lib/python3.6/dist-packages (2.1.6)
Requirement already satisfied: six>=1.9.0 in /usr/local/lib/python3.6/dist-packages (from keras) (1.11.0)
Requirement already satisfied: pyyaml in /usr/local/lib/python3.6/dist-packages (from keras) (3.12)
Requirement already satisfied: numpy>=1.9.1 in /usr/local/lib/python3.6/dist-packages (from keras) (1.14.3)
Requirement already satisfied: scipy>=0.14 in /usr/local/lib/python3.6/dist-packages (from keras) (0.19.1)
Requirement already satisfied: h5py in /usr/local/lib/python3.6/dist-packages (from keras) (2.7.1)
plotnine 0.3.0 has requirement scipy>=1.0.0, but you’ll have scipy 0.19.1 which is incompatible.
yes: standard output: Broken pipe
environment_kernels is not installed, installing…
Requirement already satisfied: environment_kernels in /usr/local/lib/python3.6/dist-packages (1.1.1)
plotnine 0.3.0 has requirement scipy>=1.0.0, but you’ll have scipy 0.19.1 which is incompatible.
yes: standard output: Broken pipe
STARTING PRE-STARTUP TASK
Collecting https://github.com/fastai/fastai/archive/master.zip
Downloading https://github.com/fastai/fastai/archive/master.zip (90.0MB)
100% |████████████████████████████████| 90.0MB 602kB/s
Requirement already satisfied (use --upgrade to upgrade): fastai==0.7.0 from https://github.com/fastai/fastai/archive/master.zip in /usr/local/lib/python3.6/dist-packages
Requirement already satisfied: bcolz in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (1.2.1)
Requirement already satisfied: bleach in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (1.5.0)
Requirement already satisfied: certifi in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2018.4.16)
Requirement already satisfied: cycler in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.10.0)
Requirement already satisfied: decorator in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (4.3.0)
Requirement already satisfied: entrypoints in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.2.3)
Requirement already satisfied: feather-format in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.4.0)
Requirement already satisfied: graphviz in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.8.3)
Requirement already satisfied: html5lib in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.9999999)
Requirement already satisfied: ipykernel in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (4.6.1)
Requirement already satisfied: ipython in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (5.5.0)
Requirement already satisfied: ipython-genutils in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.2.0)
Requirement already satisfied: ipywidgets in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (7.2.1)
Requirement already satisfied: isoweek in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (1.3.3)
Requirement already satisfied: jedi in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.12.0)
Requirement already satisfied: Jinja2 in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2.10)
Requirement already satisfied: jsonschema in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2.6.0)
Requirement already satisfied: jupyter in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (1.0.0)
Requirement already satisfied: MarkupSafe in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (1.0)
Requirement already satisfied: matplotlib in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2.1.2)
Requirement already satisfied: numpy in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (1.14.3)
Requirement already satisfied: opencv-python in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (3.4.1.15)
Requirement already satisfied: pandas in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.22.0)
Requirement already satisfied: pandas_summary in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.0.41)
Requirement already satisfied: pickleshare in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.7.4)
Requirement already satisfied: Pillow in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (5.1.0)
Requirement already satisfied: plotnine in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.3.0)
Requirement already satisfied: ptyprocess in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.5.2)
Requirement already satisfied: Pygments in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2.1.3)
Requirement already satisfied: pyparsing in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2.2.0)
Requirement already satisfied: python-dateutil in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2.5.3)
Requirement already satisfied: pytz in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2018.4)
Requirement already satisfied: PyYAML in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (3.12)
Requirement already satisfied: pyzmq in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (16.0.4)
Requirement already satisfied: scipy in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.19.1)
Requirement already satisfied: seaborn in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.7.1)
Requirement already satisfied: simplegeneric in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.8.1)
Requirement already satisfied: sklearn_pandas in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (1.6.0)
Requirement already satisfied: testpath in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.3.1)
Requirement already satisfied: torch<0.4 in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.3.0.post4)
Requirement already satisfied: torchtext in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.2.3)
Requirement already satisfied: torchvision in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.2.1)
Requirement already satisfied: tornado in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (4.5.3)
Requirement already satisfied: tqdm in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (4.23.4)
Requirement already satisfied: traitlets in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (4.3.2)
Requirement already satisfied: wcwidth in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.1.7)
Requirement already satisfied: webencodings in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.5.1)
Requirement already satisfied: widgetsnbextension in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (3.2.1)
Requirement already satisfied: six in /usr/local/lib/python3.6/dist-packages (from bleach->fastai==0.7.0) (1.11.0)
Requirement already satisfied: pyarrow>=0.4.0 in /usr/local/lib/python3.6/dist-packages (from feather-format->fastai==0.7.0) (0.9.0)
Requirement already satisfied: jupyter-client in /usr/local/lib/python3.6/dist-packages (from ipykernel->fastai==0.7.0) (5.2.3)
Requirement already satisfied: setuptools>=18.5 in /usr/local/lib/python3.6/dist-packages (from ipython->fastai==0.7.0) (39.2.0)
Requirement already satisfied: prompt-toolkit<2.0.0,>=1.0.4 in /usr/local/lib/python3.6/dist-packages (from ipython->fastai==0.7.0) (1.0.15)
Requirement already satisfied: pexpect; sys_platform != “win32” in /usr/local/lib/python3.6/dist-packages (from ipython->fastai==0.7.0) (4.5.0)
Requirement already satisfied: nbformat>=4.2.0 in /usr/local/lib/python3.6/dist-packages (from ipywidgets->fastai==0.7.0) (4.4.0)
Requirement already satisfied: parso>=0.2.0 in /usr/local/lib/python3.6/dist-packages (from jedi->fastai==0.7.0) (0.2.1)
Requirement already satisfied: jupyter-console in /usr/local/lib/python3.6/dist-packages (from jupyter->fastai==0.7.0) (5.2.0)
Requirement already satisfied: notebook in /usr/local/lib/python3.6/dist-packages (from jupyter->fastai==0.7.0) (5.2.2)
Requirement already satisfied: qtconsole in /usr/local/lib/python3.6/dist-packages (from jupyter->fastai==0.7.0) (4.3.1)
Requirement already satisfied: nbconvert in /usr/local/lib/python3.6/dist-packages (from jupyter->fastai==0.7.0) (5.3.1)
Requirement already satisfied: patsy>=0.4.1 in /usr/local/lib/python3.6/dist-packages (from plotnine->fastai==0.7.0) (0.5.0)
Requirement already satisfied: statsmodels>=0.8.0 in /usr/local/lib/python3.6/dist-packages (from plotnine->fastai==0.7.0) (0.8.0)
Requirement already satisfied: mizani>=0.4.1 in /usr/local/lib/python3.6/dist-packages (from plotnine->fastai==0.7.0) (0.4.6)
Requirement already satisfied: scikit-learn>=0.15.0 in /usr/local/lib/python3.6/dist-packages (from sklearn_pandas->fastai==0.7.0) (0.19.1)
Requirement already satisfied: requests in /usr/local/lib/python3.6/dist-packages (from torchtext->fastai==0.7.0) (2.18.4)
Requirement already satisfied: jupyter-core in /usr/local/lib/python3.6/dist-packages (from jupyter-client->ipykernel->fastai==0.7.0) (4.4.0)
Requirement already satisfied: terminado>=0.3.3; sys_platform != “win32” in /usr/local/lib/python3.6/dist-packages (from notebook->jupyter->fastai==0.7.0) (0.8.1)
Requirement already satisfied: pandocfilters>=1.4.1 in /usr/local/lib/python3.6/dist-packages (from nbconvert->jupyter->fastai==0.7.0) (1.4.2)
Requirement already satisfied: mistune>=0.7.4 in /usr/local/lib/python3.6/dist-packages (from nbconvert->jupyter->fastai==0.7.0) (0.8.3)
Requirement already satisfied: palettable in /usr/local/lib/python3.6/dist-packages (from mizani>=0.4.1->plotnine->fastai==0.7.0) (3.1.1)
Requirement already satisfied: urllib3<1.23,>=1.21.1 in /usr/local/lib/python3.6/dist-packages (from requests->torchtext->fastai==0.7.0) (1.22)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/local/lib/python3.6/dist-packages (from requests->torchtext->fastai==0.7.0) (3.0.4)
Requirement already satisfied: idna<2.7,>=2.5 in /usr/local/lib/python3.6/dist-packages (from requests->torchtext->fastai==0.7.0) (2.6)
Building wheels for collected packages: fastai
Running setup.py bdist_wheel for fastai … done
Stored in directory: /tmp/pip-ephem-wheel-cache-rkeb03c2/wheels/64/3d/9f/d12a217aa2531321c5b9ae96288fcae2687d3b744376e8f94f
Successfully built fastai
plotnine 0.3.0 has requirement scipy>=1.0.0, but you’ll have scipy 0.19.1 which is incompatible.
pip 10.0.1 from /usr/local/lib/python3.6/dist-packages/pip (python 3.6)
Requirement already satisfied: torch==0.3.0.post4 from http://download.pytorch.org/whl/cu80/torch-0.3.0.post4-cp36-cp36m-linux_x86_64.whl in /usr/local/lib/python3.6/dist-packages (0.3.0.post4)
Requirement already satisfied: pyyaml in /usr/local/lib/python3.6/dist-packages (from torch==0.3.0.post4) (3.12)
Requirement already satisfied: numpy in /usr/local/lib/python3.6/dist-packages (from torch==0.3.0.post4) (1.14.3)
plotnine 0.3.0 has requirement scipy>=1.0.0, but you’ll have scipy 0.19.1 which is incompatible.
Requirement already satisfied: torchvision in /usr/local/lib/python3.6/dist-packages (0.2.1)
Requirement already satisfied: six in /usr/local/lib/python3.6/dist-packages (from torchvision) (1.11.0)
Requirement already satisfied: pillow>=4.1.1 in /usr/local/lib/python3.6/dist-packages (from torchvision) (5.1.0)
Requirement already satisfied: torch in /usr/local/lib/python3.6/dist-packages (from torchvision) (0.3.0.post4)
Requirement already satisfied: numpy in /usr/local/lib/python3.6/dist-packages (from torchvision) (1.14.3)
Requirement already satisfied: pyyaml in /usr/local/lib/python3.6/dist-packages (from torch->torchvision) (3.12)
plotnine 0.3.0 has requirement scipy>=1.0.0, but you’ll have scipy 0.19.1 which is incompatible.
ENDING PRE-STARTUP TASK
sed: can’t read /etc/ssh/sshd_config: No such file or directory
sed: can’t read /etc/ssh/sshd_config: No such file or directory
Default ssh password for this instance is clouderizer
HOME=/content
source /content/.profile
source /content/.bashrc
ssh: unrecognized service
All setup done. Starting Clouderizer service now…
You can now login to Clouderizer console to remotely access this project.*


#4

./clouderizer_init.sh: line 225: java: command not found

this is the output I’m getting for the new command


#5

Can you try running this in one of Colab code cell?
!apt --fix-broken install

Once this is complete, run Clouderizer project script again and see if the issue goes away.


#6

Today it worked properly first attempt. Don’t know what changed.
Thanks. I’ll let you know if the issue pops up again.


#7

Colab resets your instance every 12 hours. That must be the reason why problem went away as you must be getting a fresh machine now.
Anyway, in case you see this again in future, you can try above suggestion.


#8

I’m stuck at “Starting clouderizer service” too.
These are the last lines in my terminal.

All setup done. Starting Clouderizer service now...
******You can now login to Clouderizer console to remotely access this project.*******
./install_clouderizer_service.sh: 4: [: Illegal number: 
Clouderizer files will be installed to /usr/share/java/clouderizer
Destination directory already exists.
Clouderizer service is not running.
Updating configuration files
Project ID is ********
start commnd is \/usr\/bin\/java -jar \/usr\/share\/java\/clouderizer\/clouderizer.jar **********
work dir is \/usr\/share\/java\/clouderizer
● clouderizer.service - Clouderizer Agent
   Loaded: loaded (/lib/systemd/system/clouderizer.service; enabled; vendor pres
   Active: active (running) since Sun 2018-06-24 17:18:13 CEST; 6ms ago
 Main PID: 32733 (java)
    Tasks: 16 (limit: 4915)
   CGroup: /system.slice/clouderizer.service
           └─32733 /usr/bin/java -jar /usr/share/java/clouderizer/clouderizer.ja

#9

@fabryx92 Where are you running your project? Local linux machine? If yes, can you collect logs from Clouderizer service and send over?
sudo journalctl -u clouderizer > ~/clouderizer_log.txt

This should dump the logs to clouderizer_log.txt in your home directory.

-Prakash


#10

This is the content of the log file:

Jun 25 17:15:50 deep systemd[1]: Started Clouderizer Agent.
Jun 25 17:15:50 deep clouderizer[11620]: [main] INFO com.clouderizer.client.utils.Logger - Starting Clouderizer version 1.0
Jun 25 17:15:50 deep clouderizer[11620]: [main] INFO com.clouderizer.client.utils.Logger - Home: /home/fvella user: fvella
Jun 25 17:15:50 deep clouderizer[11620]: [ClouderizerService#1529939750670] INFO com.clouderizer.client.utils.Logger - Starting Service...
Jun 25 17:15:51 deep clouderizer[11620]: javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.Alerts.getSSLException(Alerts.java:214)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1974)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1926)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.handleException(SSLSocketImpl.java:1909)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1436)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1413)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:567)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.net.www.protocol.http.HttpURLConnection.getOutputStream0(HttpURLConnection.java:1356)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.net.www.protocol.http.HttpURLConnection.getOutputStream(HttpURLConnection.java:1331)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.net.www.protocol.https.HttpsURLConnectionImpl.getOutputStream(HttpsURLConnectionImpl.java:241)
Jun 25 17:15:51 deep clouderizer[11620]:         at com.clouderizer.client.utils.ClientToServer.ClouderizerGet(ClientToServer.java:64)
Jun 25 17:15:51 deep clouderizer[11620]:         at com.clouderizer.client.service.ClouderizerService.run(ClouderizerService.java:121)
Jun 25 17:15:51 deep clouderizer[11620]: Caused by: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.validator.PKIXValidator.<init>(PKIXValidator.java:89)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.validator.Validator.getInstance(Validator.java:181)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.X509TrustManagerImpl.getValidator(X509TrustManagerImpl.java:330)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.X509TrustManagerImpl.checkTrustedInit(X509TrustManagerImpl.java:180)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.X509TrustManagerImpl.checkTrusted(X509TrustManagerImpl.java:192)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:133)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.ClientHandshaker.checkServerCerts(ClientHandshaker.java:1947)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1777)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:264)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.Handshaker.processLoop(Handshaker.java:1098)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.Handshaker.processRecord(Handshaker.java:1026)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.processInputRecord(SSLSocketImpl.java:1137)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1074)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:973)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1402)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1429)
Jun 25 17:15:51 deep clouderizer[11620]:         ... 8 more
Jun 25 17:15:51 deep clouderizer[11620]: Caused by: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/java.security.cert.PKIXParameters.setTrustAnchors(PKIXParameters.java:200)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/java.security.cert.PKIXParameters.<init>(PKIXParameters.java:120)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/java.security.cert.PKIXBuilderParameters.<init>(PKIXBuilderParameters.java:104)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.validator.PKIXValidator.<init>(PKIXValidator.java:86)
Jun 25 17:15:51 deep clouderizer[11620]:         ... 23 more
Jun 25 17:15:51 deep clouderizer[11620]: [ClouderizerService#1529939750670] ERROR com.clouderizer.client.utils.Logger - Error in Clouderizer Service
Jun 25 17:15:51 deep clouderizer[11620]: Unexpected token END OF FILE at position 0.
Jun 25 17:15:51 deep clouderizer[11620]:         at org.json.simple.parser.JSONParser.parse(JSONParser.java:257)
Jun 25 17:15:51 deep clouderizer[11620]:         at org.json.simple.parser.JSONParser.parse(JSONParser.java:81)
Jun 25 17:15:51 deep clouderizer[11620]:         at org.json.simple.parser.JSONParser.parse(JSONParser.java:75)
Jun 25 17:15:51 deep clouderizer[11620]:         at com.clouderizer.client.service.ClouderizerService.run(ClouderizerService.java:134)
Jun 25 17:15:51 deep clouderizer[11620]: [ClouderizerService#1529939750670] ERROR com.clouderizer.client.utils.Logger - Stopping Service
Jun 25 17:15:51 deep clouderizer[11620]: [Thread-0] INFO com.clouderizer.client.utils.Logger - echo Exiting clouderizer agent > /home/fvella/temp.sh
Jun 25 17:15:51 deep clouderizer[11620]: javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.Alerts.getSSLException(Alerts.java:214)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1974)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1926)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.handleException(SSLSocketImpl.java:1909)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1436)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1413)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:567)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.net.www.protocol.http.HttpURLConnection.getOutputStream0(HttpURLConnection.java:1356)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.net.www.protocol.http.HttpURLConnection.getOutputStream(HttpURLConnection.java:1331)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.net.www.protocol.https.HttpsURLConnectionImpl.getOutputStream(HttpsURLConnectionImpl.java:241)
Jun 25 17:15:51 deep clouderizer[11620]:         at com.clouderizer.client.utils.ClientToServer.ClouderizerSendStopped(ClientToServer.java:275)
Jun 25 17:15:51 deep clouderizer[11620]:         at com.clouderizer.client.MainApplication$2.run(MainApplication.java:71)
Jun 25 17:15:51 deep clouderizer[11620]: Caused by: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.validator.PKIXValidator.<init>(PKIXValidator.java:89)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.validator.Validator.getInstance(Validator.java:181)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.X509TrustManagerImpl.getValidator(X509TrustManagerImpl.java:330)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.X509TrustManagerImpl.checkTrustedInit(X509TrustManagerImpl.java:180)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.X509TrustManagerImpl.checkTrusted(X509TrustManagerImpl.java:192)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:133)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.ClientHandshaker.checkServerCerts(ClientHandshaker.java:1947)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1777)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:264)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.Handshaker.processLoop(Handshaker.java:1098)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.Handshaker.processRecord(Handshaker.java:1026)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.processInputRecord(SSLSocketImpl.java:1137)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1074)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:973)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1402)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1429)
Jun 25 17:15:51 deep clouderizer[11620]:         ... 8 more
Jun 25 17:15:51 deep clouderizer[11620]: Caused by: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/java.security.cert.PKIXParameters.setTrustAnchors(PKIXParameters.java:200)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/java.security.cert.PKIXParameters.<init>(PKIXParameters.java:120)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/java.security.cert.PKIXBuilderParameters.<init>(PKIXBuilderParameters.java:104)
Jun 25 17:15:51 deep clouderizer[11620]:         at java.base/sun.security.validator.PKIXValidator.<init>(PKIXValidator.java:86)
Jun 25 17:15:51 deep clouderizer[11620]:         ... 23 more
Jun 25 17:15:51 deep clouderizer[11620]: [Thread-0] INFO com.clouderizer.client.utils.Logger - About to kill tmux session
Jun 25 17:15:51 deep clouderizer[11620]: [Thread-5] INFO com.clouderizer.client.utils.Logger - ERROR>error connecting to /tmp/tmux-1002/default (No such file or directory)

#11

Solved by myself. The problem was due to a bug in Ubuntu 18.04

I found the solution here: https://stackoverflow.com/questions/6784463/error-trustanchors-parameter-must-be-non-empty/25188331#25188331 in the Mikael Gueck answer.


#12

Great!

Thanks for sharing your solution here.


#13

I’m facing a similar issue. On Running wget command:

–2018-09-04 06:12:44-- https://console.clouderizer.com/givemeinitsh/izmpsWfl
Resolving console.clouderizer.com (console.clouderizer.com)… 34.228.182.208
Connecting to console.clouderizer.com (console.clouderizer.com)|34.228.182.208|:443… connected.
HTTP request sent, awaiting response…
HTTP/1.1 200 OK
Server: nginx/1.10.3 (Ubuntu)
Date: Tue, 04 Sep 2018 06:12:44 GMT
Content-Type: application/octet-stream; charset=utf-8
Content-Length: 4471
Connection: keep-alive
X-Powered-By: Sails <sailsjs.org>
Access-Control-Allow-Origin:
Access-Control-Allow-Credentials:
Access-Control-Allow-Methods:
Access-Control-Allow-Headers:
Access-Control-Expose-Headers:
Content-Disposition: attachment; filename=“clouderizer_init.sh”
ETag: W/“1177-gMR/G58TWBlMQjha0HcnDg”
set-cookie: sails.sid=s%3AO7chRpNiidvk_RyhUO-w0SE_JotAk87y.XiyBlRLOtxLcgfDvUnqP4YJTY0U8Kwu6DdCHBRFdieI; Path=/; HttpOnly
Length: 4471 (4.4K) [application/octet-stream]
Last-modified header missing – time-stamps turned off.
–2018-09-04 06:12:44-- https://console.clouderizer.com/givemeinitsh/izmpsWfl
Reusing existing connection to console.clouderizer.com:443.
HTTP request sent, awaiting response…
HTTP/1.1 200 OK
Server: nginx/1.10.3 (Ubuntu)
Date: Tue, 04 Sep 2018 06:12:44 GMT
Content-Type: application/octet-stream; charset=utf-8
Content-Length: 4471
Connection: keep-alive
X-Powered-By: Sails <sailsjs.org>
Access-Control-Allow-Origin:
Access-Control-Allow-Credentials:
Access-Control-Allow-Methods:
Access-Control-Allow-Headers:
Access-Control-Expose-Headers:
Content-Disposition: attachment; filename=“clouderizer_init.sh”
ETag: W/“1177-gMR/G58TWBlMQjha0HcnDg”
Length: 4471 (4.4K) [application/octet-stream]
Saving to: ‘clouderizer_init.sh’

clouderizer_init.sh 100%[===================>] 4.37K --.-KB/s in 0s

2018-09-04 06:12:44 (408 MB/s) - ‘clouderizer_init.sh’ saved [4471/4471]

–2018-09-04 06:12:44-- https://console.clouderizer.com/givemecolabinitsh/izmpsWfl
Resolving console.clouderizer.com (console.clouderizer.com)… 34.228.182.208
Connecting to console.clouderizer.com (console.clouderizer.com)|34.228.182.208|:443… connected.
HTTP request sent, awaiting response…
HTTP/1.1 200 OK
Server: nginx/1.10.3 (Ubuntu)
Date: Tue, 04 Sep 2018 06:12:44 GMT
Content-Type: application/octet-stream; charset=utf-8
Content-Length: 17848
Connection: keep-alive
X-Powered-By: Sails <sailsjs.org>
Access-Control-Allow-Origin:
Access-Control-Allow-Credentials:
Access-Control-Allow-Methods:
Access-Control-Allow-Headers:
Access-Control-Expose-Headers:
Content-Disposition: attachment; filename=“colab_init.sh”
ETag: W/“45b8-XBvCRCDYo0Z+GeOOs+BymA”
set-cookie: sails.sid=s%3AGSdwaN2M9AT50YbUrFMzZLgfg3-WrAWl.FxbYkMUtZnjaHiBntgZIhiTrVXo%2BqZL4v3cfakUYGzU; Path=/; HttpOnly
Length: 17848 (17K) [application/octet-stream]
Last-modified header missing – time-stamps turned off.
–2018-09-04 06:12:44-- https://console.clouderizer.com/givemecolabinitsh/izmpsWfl
Reusing existing connection to console.clouderizer.com:443.
HTTP request sent, awaiting response…
HTTP/1.1 200 OK
Server: nginx/1.10.3 (Ubuntu)
Date: Tue, 04 Sep 2018 06:12:44 GMT
Content-Type: application/octet-stream; charset=utf-8
Content-Length: 17848
Connection: keep-alive
X-Powered-By: Sails <sailsjs.org>
Access-Control-Allow-Origin:
Access-Control-Allow-Credentials:
Access-Control-Allow-Methods:
Access-Control-Allow-Headers:
Access-Control-Expose-Headers:
Content-Disposition: attachment; filename=“colab_init.sh”
ETag: W/“45b8-XBvCRCDYo0Z+GeOOs+BymA”
Length: 17848 (17K) [application/octet-stream]
Saving to: ‘colab_init.sh’

colab_init.sh 100%[===================>] 17.43K --.-KB/s in 0s

2018-09-04 06:12:44 (166 MB/s) - ‘colab_init.sh’ saved [17848/17848]

Running inside Docker!
Linux version 4.14.33+ (chrome-bot@build115-m2.golo.chromium.org) (gcc version 4.9.x 20150123 (prerelease) (4.9.2_cos_gg_4.9.2-r185-2cdcfd30c27f0d836cc477f2ae9f456287fd6b1b_4.9.2-r185)) #1 SMP Sat Aug 11 08:16:53 PDT 2018
09/04/18 06:12:44 Starting Clouderizer…
If you are running clouderizer for first time on this machine, it might take some time (~10 mins) to install all pre-requisite frameworks.
Hit:1 http://security.ubuntu.com/ubuntu artful-security InRelease
Hit:2 http://archive.ubuntu.com/ubuntu artful InRelease
Hit:3 http://archive.ubuntu.com/ubuntu artful-updates InRelease
Hit:4 http://archive.ubuntu.com/ubuntu artful-backports InRelease
Reading package lists… Done
The default-jre package has already been installed.
The openssh-server package has already been installed.
The tmux package has already been installed.
The autossh package has already been installed.
The bzip2 package has already been installed.
The git package has already been installed.
The zip package has already been installed.
The unzip package has already been installed.
The curl package has already been installed.
The python package has already been installed.
The python3 package has already been installed.
The python-pip package has already been installed.
The python3-pip package has already been installed.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 4178 100 4178 0 0 4178 0 0:00:01 --:–:-- 0:00:01 9877
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 13 100 13 0 0 13 0 0:00:01 --:–:-- 0:00:01 30

The latest version of rclone rclone v1.43 is already installed.

Requirement already up-to-date: pip in /usr/local/lib/python2.7/dist-packages (18.0)
jupyter-client 5.2.3
jupyter-core 4.4.0
jupyterlab 0.33.12
jupyterlab-launcher 0.11.2
The jupyter package has already been installed.
jupyterlab 0.33.12
jupyterlab-launcher 0.11.2
The jupyterlab package has already been installed.
flask is not installed, installing…
Requirement already satisfied: flask in /usr/local/lib/python2.7/dist-packages (1.0.2)
Requirement already satisfied: Werkzeug>=0.14 in /usr/local/lib/python2.7/dist-packages (from flask) (0.14.1)
Requirement already satisfied: click>=5.1 in /usr/local/lib/python2.7/dist-packages (from flask) (6.7)
Requirement already satisfied: Jinja2>=2.10 in /usr/local/lib/python2.7/dist-packages (from flask) (2.10)
Requirement already satisfied: itsdangerous>=0.24 in /usr/local/lib/python2.7/dist-packages (from flask) (0.24)
Requirement already satisfied: MarkupSafe>=0.23 in /usr/local/lib/python2.7/dist-packages (from Jinja2>=2.10->flask) (1.0)
yes: standard output: Broken pipe
werkzeug is not installed, installing…
Requirement already satisfied: werkzeug in /usr/local/lib/python2.7/dist-packages (0.14.1)
yes: standard output: Broken pipe
Enabling: jupyterlab

  • Writing config: /usr/etc/jupyter
    • Validating…
      jupyterlab OK
      STARTING PRE-STARTUP TASK
      ./colab_init.sh: line 436: undefined: command not found
      Collecting https://github.com/fastai/fastai/archive/master.zip
      Downloading https://github.com/fastai/fastai/archive/master.zip (90.5MB)
      100% |████████████████████████████████| 90.5MB 445kB/s
      Requirement already satisfied (use --upgrade to upgrade): fastai==0.7.0 from https://github.com/fastai/fastai/archive/master.zip in /usr/local/lib/python3.6/dist-packages
      Requirement already satisfied: bcolz in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (1.2.1)
      Requirement already satisfied: bleach in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2.1.4)
      Requirement already satisfied: certifi in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2018.8.24)
      Requirement already satisfied: cycler in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.10.0)
      Requirement already satisfied: decorator in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (4.3.0)
      Requirement already satisfied: entrypoints in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.2.3)
      Requirement already satisfied: feather-format in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.4.0)
      Requirement already satisfied: graphviz in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.9)
      Requirement already satisfied: html5lib in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (1.0.1)
      Requirement already satisfied: ipykernel in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (4.6.1)
      Requirement already satisfied: ipython in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (5.5.0)
      Requirement already satisfied: ipython-genutils in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.2.0)
      Requirement already satisfied: ipywidgets in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (7.4.1)
      Requirement already satisfied: isoweek in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (1.3.3)
      Requirement already satisfied: jedi in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.12.1)
      Requirement already satisfied: Jinja2 in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2.10)
      Requirement already satisfied: jsonschema in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2.6.0)
      Requirement already satisfied: jupyter in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (1.0.0)
      Requirement already satisfied: MarkupSafe in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (1.0)
      Requirement already satisfied: matplotlib in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2.1.2)
      Requirement already satisfied: numpy in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (1.14.5)
      Requirement already satisfied: opencv-python in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (3.4.2.17)
      Requirement already satisfied: pandas in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.22.0)
      Requirement already satisfied: pandas_summary in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.0.5)
      Requirement already satisfied: pickleshare in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.7.4)
      Requirement already satisfied: Pillow in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (5.2.0)
      Requirement already satisfied: plotnine in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.4.0)
      Requirement already satisfied: ptyprocess in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.6.0)
      Requirement already satisfied: Pygments in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2.1.3)
      Requirement already satisfied: pyparsing in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2.2.0)
      Requirement already satisfied: python-dateutil in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2.5.3)
      Requirement already satisfied: pytz in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (2018.5)
      Requirement already satisfied: PyYAML in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (3.13)
      Requirement already satisfied: pyzmq in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (16.0.4)
      Requirement already satisfied: scipy in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.19.1)
      Requirement already satisfied: seaborn in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.7.1)
      Requirement already satisfied: simplegeneric in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.8.1)
      Requirement already satisfied: sklearn_pandas in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (1.7.0)
      Requirement already satisfied: testpath in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.3.1)
      Requirement already satisfied: torch<0.4 in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.3.0.post4)
      Requirement already satisfied: torchtext in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.2.3)
      Requirement already satisfied: torchvision in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.2.1)
      Requirement already satisfied: tornado in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (4.5.3)
      Requirement already satisfied: tqdm in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (4.25.0)
      Requirement already satisfied: traitlets in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (4.3.2)
      Requirement already satisfied: wcwidth in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.1.7)
      Requirement already satisfied: webencodings in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (0.5.1)
      Requirement already satisfied: widgetsnbextension in /usr/local/lib/python3.6/dist-packages (from fastai==0.7.0) (3.4.1)
      Requirement already satisfied: six in /usr/local/lib/python3.6/dist-packages (from bleach->fastai==0.7.0) (1.11.0)
      Requirement already satisfied: pyarrow>=0.4.0 in /usr/local/lib/python3.6/dist-packages (from feather-format->fastai==0.7.0) (0.10.0)
      Requirement already satisfied: jupyter-client in /usr/local/lib/python3.6/dist-packages (from ipykernel->fastai==0.7.0) (5.2.3)
      Requirement already satisfied: prompt-toolkit<2.0.0,>=1.0.4 in /usr/local/lib/python3.6/dist-packages (from ipython->fastai==0.7.0) (1.0.15)
      Requirement already satisfied: pexpect; sys_platform != “win32” in /usr/local/lib/python3.6/dist-packages (from ipython->fastai==0.7.0) (4.6.0)
      Requirement already satisfied: setuptools>=18.5 in /usr/local/lib/python3.6/dist-packages (from ipython->fastai==0.7.0) (39.1.0)
      Requirement already satisfied: nbformat>=4.2.0 in /usr/local/lib/python3.6/dist-packages (from ipywidgets->fastai==0.7.0) (4.4.0)
      Requirement already satisfied: parso>=0.3.0 in /usr/local/lib/python3.6/dist-packages (from jedi->fastai==0.7.0) (0.3.1)
      Requirement already satisfied: notebook in /usr/local/lib/python3.6/dist-packages (from jupyter->fastai==0.7.0) (5.2.2)
      Requirement already satisfied: nbconvert in /usr/local/lib/python3.6/dist-packages (from jupyter->fastai==0.7.0) (5.3.1)
      Requirement already satisfied: qtconsole in /usr/local/lib/python3.6/dist-packages (from jupyter->fastai==0.7.0) (4.4.1)
      Requirement already satisfied: jupyter-console in /usr/local/lib/python3.6/dist-packages (from jupyter->fastai==0.7.0) (5.2.0)
      Requirement already satisfied: statsmodels>=0.8.0 in /usr/local/lib/python3.6/dist-packages (from plotnine->fastai==0.7.0) (0.8.0)
      Requirement already satisfied: descartes>=1.1.0 in /usr/local/lib/python3.6/dist-packages (from plotnine->fastai==0.7.0) (1.1.0)
      Requirement already satisfied: geopandas>=0.3.0 in /usr/local/lib/python3.6/dist-packages (from plotnine->fastai==0.7.0) (0.4.0)
      Requirement already satisfied: mizani>=0.4.5 in /usr/local/lib/python3.6/dist-packages (from plotnine->fastai==0.7.0) (0.4.6)
      Requirement already satisfied: patsy>=0.4.1 in /usr/local/lib/python3.6/dist-packages (from plotnine->fastai==0.7.0) (0.5.0)
      Requirement already satisfied: scikit-learn>=0.15.0 in /usr/local/lib/python3.6/dist-packages (from sklearn_pandas->fastai==0.7.0) (0.19.2)
      Requirement already satisfied: requests in /usr/local/lib/python3.6/dist-packages (from torchtext->fastai==0.7.0) (2.18.4)
      Requirement already satisfied: jupyter-core in /usr/local/lib/python3.6/dist-packages (from jupyter-client->ipykernel->fastai==0.7.0) (4.4.0)
      Requirement already satisfied: terminado>=0.3.3; sys_platform != “win32” in /usr/local/lib/python3.6/dist-packages (from notebook->jupyter->fastai==0.7.0) (0.8.1)
      Requirement already satisfied: pandocfilters>=1.4.1 in /usr/local/lib/python3.6/dist-packages (from nbconvert->jupyter->fastai==0.7.0) (1.4.2)
      Requirement already satisfied: mistune>=0.7.4 in /usr/local/lib/python3.6/dist-packages (from nbconvert->jupyter->fastai==0.7.0) (0.8.3)
      Requirement already satisfied: shapely in /usr/local/lib/python3.6/dist-packages (from geopandas>=0.3.0->plotnine->fastai==0.7.0) (1.6.4.post2)
      Requirement already satisfied: fiona in /usr/local/lib/python3.6/dist-packages (from geopandas>=0.3.0->plotnine->fastai==0.7.0) (1.7.13)
      Requirement already satisfied: pyproj in /usr/local/lib/python3.6/dist-packages (from geopandas>=0.3.0->plotnine->fastai==0.7.0) (1.9.5.1)
      Requirement already satisfied: palettable in /usr/local/lib/python3.6/dist-packages (from mizani>=0.4.5->plotnine->fastai==0.7.0) (3.1.1)
      Requirement already satisfied: urllib3<1.23,>=1.21.1 in /usr/local/lib/python3.6/dist-packages (from requests->torchtext->fastai==0.7.0) (1.22)
      Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/local/lib/python3.6/dist-packages (from requests->torchtext->fastai==0.7.0) (3.0.4)
      Requirement already satisfied: idna<2.7,>=2.5 in /usr/local/lib/python3.6/dist-packages (from requests->torchtext->fastai==0.7.0) (2.6)
      Requirement already satisfied: munch in /usr/local/lib/python3.6/dist-packages (from fiona->geopandas>=0.3.0->plotnine->fastai==0.7.0) (2.3.2)
      Requirement already satisfied: click-plugins in /usr/local/lib/python3.6/dist-packages (from fiona->geopandas>=0.3.0->plotnine->fastai==0.7.0) (1.0.3)
      Requirement already satisfied: cligj>=0.4 in /usr/local/lib/python3.6/dist-packages (from fiona->geopandas>=0.3.0->plotnine->fastai==0.7.0) (0.4.0)
      Requirement already satisfied: click>=3.0 in /usr/local/lib/python3.6/dist-packages (from click-plugins->fiona->geopandas>=0.3.0->plotnine->fastai==0.7.0) (6.7)
      Building wheels for collected packages: fastai
      Running setup.py bdist_wheel for fastai … done
      Stored in directory: /tmp/pip-ephem-wheel-cache-n_der807/wheels/64/3d/9f/d12a217aa2531321c5b9ae96288fcae2687d3b744376e8f94f
      Successfully built fastai
      pip 18.0 from /usr/local/lib/python3.6/dist-packages/pip (python 3.6)
      Requirement already satisfied: torch==0.3.0.post4 from http://download.pytorch.org/whl/cu80/torch-0.3.0.post4-cp36-cp36m-linux_x86_64.whl in /usr/local/lib/python3.6/dist-packages (0.3.0.post4)
      Requirement already satisfied: pyyaml in /usr/local/lib/python3.6/dist-packages (from torch==0.3.0.post4) (3.13)
      Requirement already satisfied: numpy in /usr/local/lib/python3.6/dist-packages (from torch==0.3.0.post4) (1.14.5)
      Requirement already satisfied: torchvision in /usr/local/lib/python3.6/dist-packages (0.2.1)
      Requirement already satisfied: numpy in /usr/local/lib/python3.6/dist-packages (from torchvision) (1.14.5)
      Requirement already satisfied: torch in /usr/local/lib/python3.6/dist-packages (from torchvision) (0.3.0.post4)
      Requirement already satisfied: six in /usr/local/lib/python3.6/dist-packages (from torchvision) (1.11.0)
      Requirement already satisfied: pillow>=4.1.1 in /usr/local/lib/python3.6/dist-packages (from torchvision) (5.2.0)
      Requirement already satisfied: pyyaml in /usr/local/lib/python3.6/dist-packages (from torch->torchvision) (3.13)
      ENDING PRE-STARTUP TASK
      Default ssh password for this instance is clouderizer
      HOME=/content
      source /content/.profile
  • Restarting OpenBSD Secure Shell server sshd
    …done.
    09/04/18 06:13:04 All setup done. Total Setup Time : 0 minutes
    Starting Clouderizer service now…
    You can now login to Clouderizer console to remotely access this project.*

This is the output log which show that Clouderizer should be setup by now but machine is still showing “Starting” status instead of “Running”.


#14

This should be resolved now.


#15

Thanks. It’s working now