The Jupyter notebook can not find the Fastai library


#1

Hi,

I followed you blog post to use fastai on Clouderizer using Google Colab (and this blog post too). Worked very well on Wednesday but not this morning (Saturday).

The Jupyter Notebook (dl1/lesson1.ipynb) can not find the Fastai library.

Can you help ? Thanks.


#2

Where are you running the project, Google Colab or your local machine?


#3

Hello @prakash, yes. Google Colab.

If you want, I can send you my email used as login of my Clouderizer account.


#4

Hi, i would need the logs on Colab notebook to see what would have gone wrong. Can you do the following?

  1. Stop the project on Clouderizer console.
  2. Run the startup command again on Colab notebook.

Once the project starts running again, check if you still see the error. If yes, send me the logs on the Colab notebook code block.


#5

Thanks. Same problem. I sent you my logs to your profile mail.


#6

Can you send it to prakash@clouderizer.com ?


#7

Thanks @prakash.

I sent my logs (from my Colab notebook) to you (after a restart as you asked for).


#8

Logs look all normal.
You can try restarting Jupyter Notebook on that machine.

  1. Go to Clouderizer console.
  2. On your running fast.ai project card, click on “Send Command” button.
    24 PM
  3. Type command restart_jupyter and press OK.
  4. This should restart Jupyter notebook on Colab instance. Try accessing Jupyter notebook now and see if you still see this error.

In case the error still persists, you can restart the colab instance itself.

  1. Go to Colab Notebook and stop Clouderizer Service code block.
  2. In a new block type and execute following command
    !kill -9 -1
  3. Wait for 10-15 seconds and then forcefully stop this query as well.
  4. In a new code block, run Clouderizer startup command again.

Let me know if these help.


#9

Hello @prakash,

I’m experimenting your 2 solutions but one thing I just noticed : I thought I used more or less 12h until this morning in my Fastai project but I see now more than 88 hours ???

clouderizer


#10

@prakash, my jupyter notebook works now :slight_smile: Many thanks !

I applied your 2 solutions but I have to confess that I did forget something important this morning : to change my Colab notebook to python 3 and GPU :frowning: (read “First, WTF is Google Colab?”)


#11

yes. Python 3 and GPU setting is important for fast.ai project.

Happy to hear its working for you now.


#12

This number is actually a measure of # of hours project runs on hardware. In case you didn’t stop the project explicitly from console or directly from Colab notebook, Clouderizer service continues to run. Even if you are not logged in to Clouderizer console. This is important when your machine learning model needs to train for long hours.